题目
题目描述
Queues and Priority Queues are data structures which are known to most computer scientists. The
Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the
queue in front of the Mensa is a team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches
the queue from head to tail to check if some of its teammates (elements of the same team) are already
in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail
and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are
processed from head to tail in the order they appear in the team queue.
Your task is to write a program that simulates such a team queue.
输入格式
The input file will contain one or more test cases. Each test case begins with the number of teams
t (1 ≤ t ≤ 1000). Then t team descriptions follow, each one consisting of the number of elements
belonging to the team and the elements themselves. Elements are integers in the range 0..999999. A
team may consist of up to 1000 elements.
Finally, a list of commands follows. There are three different kinds of commands:
• ENQUEUE x — enter element x into the team queue
• DEQUEUE — process the first element and remove it from the queue
• STOP — end of test case
The input will be terminated by a value of 0 for t.
Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation
of the team queue should be efficient: both enqueing and dequeuing of an element should
only take constant time.
输出格式
For each test case, first print a line saying ‘Scenario #k’, where k is the number of the test case. Then,
for each ‘DEQUEUE’ command, print the element which is dequeued on a single line. Print a blank line
after each test case, even after the last one.
样例输入
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 |
2 3 101 102 103 3 201 202 203 ENQUEUE 101 ENQUEUE 201 ENQUEUE 102 ENQUEUE 202 ENQUEUE 103 ENQUEUE 203 DEQUEUE DEQUEUE DEQUEUE DEQUEUE DEQUEUE DEQUEUE STOP 2 5 259001 259002 259003 259004 259005 6 260001 260002 260003 260004 260005 260006 ENQUEUE 259001 ENQUEUE 260001 ENQUEUE 259002 ENQUEUE 259003 ENQUEUE 259004 ENQUEUE 259005 DEQUEUE DEQUEUE ENQUEUE 260002 ENQUEUE 260003 DEQUEUE DEQUEUE DEQUEUE DEQUEUE STOP 0 |
样例输出
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 |
Scenario #1 101 102 103 201 202 203 Scenario #2 259001 259002 259003 259004 259005 260001 |
题解
代码
c++
#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
int team[1000002],cnt;
string s;
int t;
int main(){
while(scanf("%d",&t)!=EOF){
cnt++;
queue<int>tque[1001];
queue<int>mque;
int flag=0;
for(int i=1;i<=t;i++){
int num;
scanf("%d",&num);
for(int j=1;j<=num;j++){
int tmp;
scanf("%d",&tmp);
team[tmp]=i;
}
}
while(cin>>s){
if(s=="STOP"){
printf("\n");
break;
}
if(s=="ENQUEUE"){
int num;
scanf("%d",&num);
if(tque[team[num]].empty()){
mque.push(team[num]);
tque[team[num]].push(num);
}
else tque[team[num]].push(num);
}
if(s=="DEQUEUE"){
if(flag==0){
printf("Scenario #%d\n",cnt);
flag=1;
}
while(tque[mque.front()].empty()){
mque.pop();
}
printf("%d\n",tque[mque.front()].front());
tque[mque.front()].pop();
}
}
}
<pre><code>return 0;
</code></pre>
}